1570 won't play BluRay disc properly. Help

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • Joe Fagan
    Junior Member
    • Dec 2009
    • 5

    1570 won't play BluRay disc properly. Help

    Tried to play my first BluRay disc tonight and am having problems. The BluRay disc is the current Star Trek movie. The Oppo BD BluRay displays True DD. The 1570 displays Dolby HD Dmix 48k with subscript showing only the FL FR and SW playing. When I turn 1570 off and then on again that first display shows only the FL FR and SW speakers. If I switch to the Direct TV input the display shows the 5.1 speakers. Going to menus there is no difference between the two inputs with both being HDMI. Would like to have all 5.1 speakers active and the 48k bing 96k. Any suggestions will be most appreciated. Thanks in advance. Joe Fagan
  • hurin
    Senior Member
    • Sep 2009
    • 118

    #2
    My guess would be the Oppo is the culprit. You probably have it set to output 2.0 PCM, that would still activate the sub but not the rears. Have you set PiP sound to 'off'?

    As far I know there is not a single movie out yet with 96khz sound. A loosless 48khz soundtrack is still a huge improvement over ordinary DD though. The only releases with 96khz sound are concert Blu Rays like this one.

    Comment

    • Joe Fagan
      Junior Member
      • Dec 2009
      • 5

      #3
      Thanks for the suggestion

      I do have PIP off and the Oppo is set for HDMI video and audio with the audio set for bitstream and other options generally set for automatic as suggested by Oppo for BluRay discs. I appreciate the info about BluRay movies being only 48 k. The Oppo does read the disc as True Dolby and the 1570 reports receiving True Dolby. This makes me think that the 1570 is receiving the video and audio data. But then the 1570 eliminates the center and surround channels. The setup is exactly the same for Direct TV and DVDs. For everything else all the speakers are energized as appropriate except the BluRay. If anything else occurs to your I'm willing to try anything. Thanks again for the suggestions. Joe Fagan

      Comment

      • Kevin D
        Ultra Senior Member
        • Oct 2002
        • 4601

        #4
        The 1570 has different options for each sound type and will remember those each time it encounters it. It's currently set to the 2ch downmix setting for Dolby TrueHD.

        I don't have a source that will stream the new formats, so I'm not sure on the exact procedure. Hitting the PLIIx MODE button on the front may scroll through the different options but you may have to hit the SURR+ button on the remote and then use the left/right cursor keys to go through them.

        Once changed to regular TrueHD (or TrueHD+PLIIx if you have 7.1) it should remember it until changed again.

        Kevin D.

        Comment

        • Joe Fagan
          Junior Member
          • Dec 2009
          • 5

          #5
          Your suggestion along with Rotels help fixed my problem.

          My solution was to go to Advanced Speaker setup and configure Dolby to Master. Next it was to manually change Dolby Downmix ( 2channel) to Dolby True which activated the 5.1 speakers. Then I switched the 1570 off and back on and retried the BluRay disc and it switched to Dolby True with all 5.1 channels. This fix is not perfect as I am having to do it for each DVD but that is ok. Thanks to all who helped. Joe Fagan

          Comment

          • Mikael
            Senior Member
            • Aug 2007
            • 379

            #6
            Hi Have you tried to go to the input menu on the RSP1570 and scroll down to to the defailt mode and change that setting from the 2ch downmix to the true HD 5.1 setting? that should do the trick so don't have to do it every time.

            Best Mikael

            Comment

            Working...
            😀
            😂
            🥰
            😘
            🤢
            😎
            😞
            😡
            👍
            👎
            Searching...Please wait.
            An unexpected error was returned: 'Your submission could not be processed because you have logged in since the previous page was loaded.

            Please push the back button and reload the previous window.'
            An unexpected error was returned: 'Your submission could not be processed because the token has expired.

            Please push the back button and reload the previous window.'
            An internal error has occurred and the module cannot be displayed.
            There are no results that meet this criteria.
            Search Result for "|||"