Please Help: Sound delay with rsx 1065

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • jrhodus
    Junior Member
    • Jun 2003
    • 10

    Please Help: Sound delay with rsx 1065

    Hopefully, somebody can help me with a problem anf a solution.

    I have a Rotel 1065 receiver and a Zennith hd 520 high def OTA/Direct TV settop box. The Zennith connects to the Rotel using a Opital digital cable for sound. When I change channels I have a 2 to 3 second delay where there is no sound. It doesn't matter if it is off the attenna or thru direct tv.

    My dealer tells me that it is normal and that all of their Rotels (1066--1065, etc) do it too. I first emailed Rotel and he acted like that it shouldn't be that way, but I should work thru the dealer. The dealer acted like I should deal with Rotel.

    I have two DVD players that connect thru digital coaxil for sound. There is no delay when changing back and forth between them.

    When I bought the receiver it was implied that it passed Hi def signals, but I since found out that it doesn't. I asked the dealer if it could be upgraded and he said that he didn't know. They have had my receiver for 10 days and it's getting frustrating.

    Is this normal? Does naybody else have or not have this problem?

    Thanks for your help.

    James Rhodus
  • aud19
    Twin Moderator Emeritus
    • Aug 2003
    • 16706

    #2
    Sounds like you've unfortunately encountered a less than co-operative and less than helpful dealer. I think Rotel is counting on the fact that the dealer would be able to help you more efficiently, would be able to deal directly face to face with you etc. Unfortunately that means they're counting on him being a good dealer. I know I've seen other reports on here regarding sound delays, try to do a search for that info. As for the HD signals. I know the 1066/1055 are upgradeable for HD signals on the older units that only had the low frequency video capabilities not sure about the 1065 though. I'd try Rotel again and look for info on this board. I'm not even an owner (yet ) and Rotel responded well and quickly to any of my questions.

    J.R.




    Need a new display? Questions about new display technologies? Visit RPTVs, plasmas, and other monitors @ HTguide
    Jason

    Comment

    • jrhodus
      Junior Member
      • Jun 2003
      • 10

      #3
      J.R.

      Thanks for reply. I did a search and most comments about any type of delay are from April and they seem to deal mostly with DVDs. I'm trying to see if this is a common problem and if there is a solution. My dealer tells me that this is normal. I find that hard to believe. I love the Rotel sound, but this is enough to drive me crazy.

      Thanks

      James

      Comment

      • ejfiii
        Member
        • May 2003
        • 87

        #4
        I too have a 1065 and HD cable. I have a Sci Atl 3100 HD box though. Anyway, it has been my experience that the delay in sound when switching channels is when I switch from HD & Digital channels to Analog channels and vise versa. Reason being that the 1065 is trying to lock on the digital coax or toslink connection signal first, then checks the analog connection if no digital signal is present. But it really only happens when going from analog channels to digital channels.

        As for passing HD signals, I route my cable box directly to the hd inputs on the plasma, bypassing the 1065. But I route my dvd through it with no problem. I seem to recall this being discussed a lot and the consensus is that it should pass the HD signal. If you have tried it and it doesn't not work, you should get your 1065 serviced and upgraded to fix the problem.

        Good luck dealing with a crummy sounding dealer.

        E. J.




        My HT
        My HT

        Comment

        • Danbry39
          Moderator Emeritus
          • Sep 2002
          • 1584

          #5
          If I'm understanding you correctly, this happens even if you're switching channels off of a regular antenna feed? Then, I feel it shouldn't be happening. Sounds like your dealer's a flake. Maybe he's related to the dealer who told me that double-bass was a good thing. Geez. Follow the advise given above. Contact Rotel directly and bypass the dealer altogether, although I'd definitely let them know who the dealer is and what they've been feeding you. You might want to ask for Mike.




          Keith
          Keith

          Comment

          • jrhodus
            Junior Member
            • Jun 2003
            • 10

            #6
            Thanks for your help Guys.

            The sound delay problem doesn't sound right to me, but they say it is normal and that the Rotel stuff they have at the store and at home does it too. Hopefully it is something Rotel and a new firmware can fix.

            I told them that I was told it could pass HD signals (i hook my settop box directly to the TV, but what if I want to change something later on) when I bought it, but that seemed to go over their heads. When I took it in to be looked at, my salesman ( he was useless--if I hadn't liked the rotel product--I wouldn't have bought it ) was standing there but he didn't say a thing. At this point a he said this or that would be useless, so I didn't make a stink about it. They then said that they didn't know if it could be upgraded or not ( I know it can be done from this forum) and that they will contact Rotel. I have asked about this several times, but they keep forgetting to do it or just not doing anything about it.

            Their first response when I called them about these problems, was for me to call Rotel, but that they would be happy to send it back to Rotel for me. They just might as well be a internet dealer for the help that they have given me. I do know one thing, I'll never buy anything from them agin.

            Rotel has been prompt and wanting to help ( I first contacted them) with the problems. They asked me to contact my dealer so that that we could all work together to solve this problem. I had no problem with this, but I didn't know thet Dealer would so helpless. Tim Wyatt, whom I was corresponding with at Rotel, even called me at home to answer a question that I had. I just asked for an email reponse but he called me on a Saturday!!!

            Agin, thanks for help

            James

            PS.. My DVD players which are hooked up by digital coaxil don't have this problem. Would a Converter to change the digital optical to a digital coaxil signal possibly work. Maybe its a delay in the Rotel converting the optical signal??? I might be barking up the wrong tree, but I just want to fix the problem as I love the sound of the Rotel.

            Comment

            • ejfiii
              Member
              • May 2003
              • 87

              #7
              jrhodes,

              Before making Rotel jump through hoops, answer our questions above. Is the delay there when changing each and every channel, or only when going from digital to analaog and back again? As I pointed out above, it is normal (still annoying) for the rotel to search for the digital signal first, and then default to analog when switching channels between the two. DVD will have nothing to do with it.

              So, once you determine that, maybe we can help more.

              E. J.




              My HT
              My HT

              Comment

              • jrhodus
                Junior Member
                • Jun 2003
                • 10

                #8
                E.J.

                The delay is with changing from any channel to another. It doesn't matter if it is direct TV or the attenna (SD or HD signal). It occurs going from Direct TV to Direct TV (it doesn't matter which channel), Direct TV to Attenna, Attenna to Attenna, Attenna to Dirct TV. I'm sorrry, I thought I had stated this (in not so many words) in an earlier post. Agin, I'm sorry for the confusion.

                Addendum: The Dealer did agree to pay for the HD upgrade cost, but if it had to be sent back to Rotel, that I would have to pay the shipping. This still doesn't address the sound delay, but at least it is something.

                Thanks

                James

                Comment

                • Danbry39
                  Moderator Emeritus
                  • Sep 2002
                  • 1584

                  #9
                  Request that Rotel upgrade the firmware to the most recent version while it's there. Hopefully, that might help clear up your problem and I think Rotel will do it for free.




                  Keith
                  Keith

                  Comment

                  • jrhodus
                    Junior Member
                    • Jun 2003
                    • 10

                    #10
                    I have already done that myself, but thanks for the advice. I hope that the delay will be able to fixed with a firmware upgrade at some point. Hopefully Rotel will be able to come up with something.

                    Thanks

                    James

                    Comment

                    • ejfiii
                      Member
                      • May 2003
                      • 87

                      #11
                      Well, after your clarification of the issue, it definately sounds like there is something wrong with your unit. I get no delay on my most channel changes, only when going from analog to digital and back. This is my second 1065 and I did not notice a delay like you are describing on either of them. I would force the dealer or Rotel to take care of the obvious problem with the unit. Are you still in your return window? Maybe take it back and find a more helpful dealer.

                      Good luck,

                      E. J.




                      My HT
                      My HT

                      Comment

                      Working...
                      Searching...Please wait.
                      An unexpected error was returned: 'Your submission could not be processed because you have logged in since the previous page was loaded.

                      Please push the back button and reload the previous window.'
                      An unexpected error was returned: 'Your submission could not be processed because the token has expired.

                      Please push the back button and reload the previous window.'
                      An internal error has occurred and the module cannot be displayed.
                      There are no results that meet this criteria.
                      Search Result for "|||"