bought rmb 1075, protection lights go on w/trigger

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • mariachi
    Member
    • Aug 2003
    • 39

    bought rmb 1075, protection lights go on w/trigger

    I just bought the 1075, i'm using it w/12 volt trigger and when I turned it off through my receiver, I noticed that all the protection lights when up. is this normal? I didn't look at the front panel when I first turned it on as I was still hooking things up in the back.

    -Vic
  • I'mListening
    Member
    • Jul 2003
    • 63

    #2
    My system is new to me...but my 1075 and 1050 do not light up when the RSP1066 is powered down (Standby mode). I aways wondered if they are actually shutting off since the Blue LED is always on.




    Thanks for reading!

    Enter The Cyberdyne Cinema

    Darren
    Thanks for reading!

    Enter The Cyberdyne Cinema

    Darren

    Comment

    • Kevin D
      Ultra Senior Member
      • Oct 2002
      • 4601

      #3
      Our 1075 at the store will light them for a little bit when using the 12v trigger. Are yours slowly fading out? If so, all is normal.

      Kevin D.

      Comment

      • Scarp
        Senior Member
        • Mar 2003
        • 632

        #4
        As long as they don't stay on then its normal.

        If you read the manual you well see something mentioned that protects the unit from taking to much power at once when its turned on. So when turning on it will turn on its protection and slowly turn it off and take in power slowly.

        I accidently didn't turn on my RB1090 properly. So I pressed the button, the lights went on (also the red ones) but i didn't push the button hard it enough so it went off again, then i pressed it again and somehow it didn't use its protection (because of the latency of the power), so it took all power at once and blew a fuse in my house's fusebox (not in the amp).
        A 16 Amp fuse blew !

        I know someone with a Krell amp, who had that happen everytime he turned the damn thing on and had to replace the fuse with a 20 amp one.

        So, don't worry as long as they turn off.

        Comment

        • Andrew Pratt
          Moderator Emeritus
          • Aug 2000
          • 16507

          #5
          Yes this is perfectly normal.




          Comment

          • HowardGjr
            Junior Member
            • Jan 2003
            • 19

            #6
            Andrew is correct (as usual),this behavior is by design. I think its so you can tell the 12V trigger signal is no longer present and the device has shut off.

            From Rotel FAQ for RMB-1075

            With the 12 volt trigger connected, the amplifier’s standby LED does not turn off when the preamplifier is shut down.
            The RMB 1075’s standby LED will always remain on when the unit is controlled by the 12 volt trigger to indicate when the unit is in standby mode and is only drawing minimal power. A visible sign that the amplifier is turning off or on is the protection circuitry should engage briefly when the amp is powered on or off by the triggers.

            Comment

            • mariachi
              Member
              • Aug 2003
              • 39

              #7
              Yes, thanks everyone. I'm glad this is perfectly normal.

              -Vic

              Comment

              Working...
              😀
              😂
              🥰
              😘
              🤢
              😎
              😞
              😡
              👍
              👎
              Searching...Please wait.
              An unexpected error was returned: 'Your submission could not be processed because you have logged in since the previous page was loaded.

              Please push the back button and reload the previous window.'
              An unexpected error was returned: 'Your submission could not be processed because the token has expired.

              Please push the back button and reload the previous window.'
              An internal error has occurred and the module cannot be displayed.
              There are no results that meet this criteria.
              Search Result for "|||"