No sound problem with Sony STRDA777ES receiver

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • DavidY
    Member
    • Aug 2000
    • 67

    No sound problem with Sony STRDA777ES receiver

    When I returned home today, I turned on the receiver, TV, CD, and VCR via Cinema 7 remote's macro....no sound from any source. Checked all the connections on the back of the receiver...no loose connections. My 1 year old Sony 777ES receiver has been running fine for the past 2.5 months since it was repaired (major flameout due to a possible shortcircuit: Sony Canada replaced mainboard, IC's, transformers, etc.).

    One possible solution is to replace the Sony receiver with my Technics receiver and DD/DTS decoder from my bedroom system. However, I would have to remove all the banana connections on the speaker cables so they can fit into the Technics speaker clips.

    And I don't want to once again return (read: move) this 60 pound box back to my local dealer. Transporting this receiver down three flights of stairs is a real pain.

    Any other tips before I try this?

    Dave
  • Lex
    Moderator Emeritus
    • Apr 2001
    • 27461

    #2
    Is it powering up? Fuse if not, perhaps. But either way, your looking at a dealer trip. I say make Sony eat it and get you a new piece. You shouldn't have to take this kind of quality. Unfortunately, that's been my experience with Sony last few years. Goodluck!

    Lex
    Doug
    "I'm out there Jerry, and I'm loving every minute of it!" - Kramer

    Comment

    Working...
    😀
    😂
    🥰
    😘
    🤢
    😎
    😞
    😡
    👍
    👎
    Searching...Please wait.
    An unexpected error was returned: 'Your submission could not be processed because you have logged in since the previous page was loaded.

    Please push the back button and reload the previous window.'
    An unexpected error was returned: 'Your submission could not be processed because the token has expired.

    Please push the back button and reload the previous window.'
    An internal error has occurred and the module cannot be displayed.
    There are no results that meet this criteria.
    Search Result for "|||"