1055 Question

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • Nate
    Junior Member
    • Feb 2003
    • 10

    1055 Question

    I am new to Club Rotel and I had a question about the updates being posted on Andrew's website. I bought my 1055 in August, and it had worked great! About 3 weeks ago, while watching a movie, the sound cut out. The power light was on, but no display and sound. I sent it back to where I bought it, and they gave me a new one about a week later. I was never told what the problem was, but it must have been something they couldn't fix. I now have the version 2.2.2, and i wanted to be sure that the new updates have worked well for the 1055. I don't want to bring in another unit! Thanks for the help.

    Nate
  • gianni
    Senior Member
    • Nov 2002
    • 524

    #2
    I have a 2.2.2 version 1055. Got it in mid Dec. and it has been flawless.

    Comment

    • Nate
      Junior Member
      • Feb 2003
      • 10

      #3
      Oh...I didn't word that right. Are you talking about the new updates that are on Andrew's website? I wanted to know if the new software that everyone is downloading will work fine for the 1055. I would really like to get rid of the Rec feature on the display, and I see that most people who have downloaded the software are using the 1066.

      Comment

      • Andrew Pratt
        Moderator Emeritus
        • Aug 2000
        • 16507

        #4
        Nate I was using the version that is listed on my site in my 1055 for a while without any issue and am now using the new "beta" firmare and its solid as well. If you want that (2.25) send me an email and I'll send it to you. So far no ones complained about the 2.25 being buggy at all so IMO its safe to use




        Comment

        • RandyH
          Junior Member
          • Apr 2003
          • 5

          #5
          ...I bought my 1055 in August, and it had worked great! About 3 weeks ago, while watching a movie, the sound cut out. The power light was on, but no display and sound. I sent it back to where I bought it, and they gave me a new one about a week later. I was never told what the problem was, but it must have been something they couldn't fix. I now have the version 2.2.2, and i wanted to be sure that the new updates have worked well for the 1055. I don't want to bring in another unit! Thanks for the help.

          Nate


          Nate...I had exactly the same thing happen the other day....sound cut out...no display...power light on. My 1055 is in the shop now and I've not heard what they found to be the problem. Did they resolve the problem with your new unit? Has anyone else had this happen?...oh btw, my blowout was also accompanied by a small puff of smoke from the top of the unit. Yikes!!!

          Randy

          Comment

          • Nate
            Junior Member
            • Feb 2003
            • 10

            #6
            I turned in the unit to my dealer and they gave me a RSX-972 while my receiver was being fixed. I was pretty grateful for that! They said it would take a few weeks, but after one week, they called and said that they were giving me a new one. I asked what the problem was, and they said that Rotel didn't give a reason.
            I don't remember seeing a puff of smoke, but mine was in a cabinet, so I am not sure. I haven't had any problems after that. It actually worked out better, because the first one that I had didn't have the update for the HD bandwidth. I hope everything goes well with yours.

            Nate

            Comment

            • georose
              Junior Member
              • Apr 2003
              • 17

              #7
              I hope this is not going to become a trend. I had my Rotel 1055 for 2 days using the pre outs to power tri-amped Linn 5140 speakers for stereo. Amazing sound - better than my Linn Majic pre amp section. After the 2 days of listening to CD's I got around to surround sound. Then a puff of smoke and that burning vinyl smell and the Rotel was dead. It happened after I hooked up a pair of B&W 805's and CDM center channel speakers and used the Rotel amps for the first time. I could have shorted the speaker wires but that shouldn't cause a catastrophe - should it?

              Comment

              • RandyH
                Junior Member
                • Apr 2003
                • 5

                #8
                Wow...sorry to hear that. I had been using my 1055 in a surround system for 6 months with no problems. I moved everything to another room and initially connected just the two main speakers and listened to stereo for a few days while I finished setting up my surrounds. As soon as I connected the surrounds and started watching a movie (about 5 minutes) she blew.

                I called my dealer today after waiting the two weeks they told me it would take to get it repaired at their authorized service center and they told me something like the "main board", "front board", or "front panel board" (I don't remember for sure) was out and that for this type of repair they had to send it to Rotel....which will probably involved another two weeks. Seems to me that this is way to long to wait for repairs on a practically new product. I've written to Rotel requesting a replacement.

                This is very discouraging......

                Randy

                Comment

                Working...
                Searching...Please wait.
                An unexpected error was returned: 'Your submission could not be processed because you have logged in since the previous page was loaded.

                Please push the back button and reload the previous window.'
                An unexpected error was returned: 'Your submission could not be processed because the token has expired.

                Please push the back button and reload the previous window.'
                An internal error has occurred and the module cannot be displayed.
                There are no results that meet this criteria.
                Search Result for "|||"