RMB1075 channel dead

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • JP
    Member
    • Feb 2003
    • 32

    RMB1075 channel dead

    Hey guys, so this has happened in the past. ( I drop an RCA cable and it falls on the positive/negative speaker terminals, I curse myself and then replace the fuse kinda thing) This time though, no such easy resolution. I come back from vacation just 2 days ago. The power had gone out a few days earlier, no big deal it happens. I have a MonsterCable HTS3500 surge/line filter on a dedicated 20 amp circuit. (I'm not worried) I turn the surge back on and then I turn the amp on. The front right speaker crackles for a bit. Other than that everything seems fine. So I start watching all my previous TIVO stuff. I don't notice the right speaker working until I start to play some XBox. No sound at all! So, I disconnect cables and pull the amp out. Check the fuses, they look OK, so I check cables, and check cables, and check some more. Everything looks good. So I pull it out again, I test each individual channel with 1 incomiong signal and the front right speaker. They all work except for the right side of the amp. Uggghhhhh All the fuses are good, I don't see any damage on the boards, and I am at a loss. any ideas?? I already contacted Rotel service and am waiting to hear back. But I am moving so this may be a problem. I can't take it to my 'dealer' because I bought it from Rotel directly. (don't ask) Thanks to all!!

    JP
  • Andrew Pratt
    Moderator Emeritus
    • Aug 2000
    • 16507

    #2
    sorry other then making sure the fuses are ok I'm not sure what else you might be able to do. Is the protection light lite up on the front of the unit?




    Comment

    • JP
      Member
      • Feb 2003
      • 32

      #3
      Andrew, yes the lights come on. So im at a loss. A friend of mine is going to drive it up to Rotel in Reading, MA as I am already in California

      thanks!

      jp

      Comment

      Working...
      Searching...Please wait.
      An unexpected error was returned: 'Your submission could not be processed because you have logged in since the previous page was loaded.

      Please push the back button and reload the previous window.'
      An unexpected error was returned: 'Your submission could not be processed because the token has expired.

      Please push the back button and reload the previous window.'
      An internal error has occurred and the module cannot be displayed.
      There are no results that meet this criteria.
      Search Result for "|||"