B&K Ref 50 Series 1 Latest Firmware

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • Hoopofficial
    Member
    • Dec 2004
    • 44

    B&K Ref 50 Series 1 Latest Firmware

    I have two of these pre-amps and absolutely love them. One (bought new many years ago) has Version 2.02 and one (just bought used) has Version 2.03. Just wondering what the latest firmware is and what the benefits are. Not looking to upgrade them to the Series 2. I was planning on calling B&K to see what they can do with one of them to upgrade DAC's but not sure if they will even do that with this unit anymore. Any comments are appreciated. Thanks.
  • John Holmes
    Moderator Emeritus
    • Aug 2000
    • 2703

    #2
    I had my S1 upgraded to FW 2.0.3 from 1.0.7 or 6... whatever the original was.

    The two biggest changes were, no more clicking when changing sources and the THX Ultra 2 displays on the unit now.

    I don't know if DAC's were done or not. I do know that it seemes to sound a little more detailed. But, not that it didn't sound good and detailed before the upgrade.
    "I have come here, to chew bubblegum and kickass. And I'm all out of bubblegum!!!"

    Comment

    • orobert
      Junior Member
      • Jan 2010
      • 4

      #3
      Hello,

      I bought a few weeks ago a used Reference 50 (S1) preamp.
      Firmware version is 1.04, BKC-DIP version is 1.02.01
      The preamp works fine, I still have a few problems, with BKcSuite:
      - I have downloaded on B&K web site the complete version of BKcSuite,
      version 3.9.0.76. I tried to use the virtual mode, but it still tries to
      communicate with the device, and stays on the "Interrogating Device" window.
      - I tried to connect it to the preamp, select correct COM port, speed,
      .... The software detects correctly the Reference 50, but then it stays
      again on the "Interrogating Device" window (attached is the data
      exchange beetween computer and preamp, sniffed on COM port. No more
      communication after this, stays on "Interrogating Device").
      Do you know if the BKcSuite software, and the last version, work with the Reference 50 preamp or do I need an older version (I did not got the original CDROM with the preamp)?

      I would like to upgrade to 2.03, I asked B&K, they told me it would cost 150$ plus shipping. I live in France, shipping alone is more than the value of the preamp (and no B&K dealer in Europe). So that's not an option.

      Thanks for your help.

      Comment

      Working...
      😀
      😂
      🥰
      😘
      🤢
      😎
      😞
      😡
      👍
      👎
      Searching...Please wait.
      An unexpected error was returned: 'Your submission could not be processed because you have logged in since the previous page was loaded.

      Please push the back button and reload the previous window.'
      An unexpected error was returned: 'Your submission could not be processed because the token has expired.

      Please push the back button and reload the previous window.'
      An internal error has occurred and the module cannot be displayed.
      There are no results that meet this criteria.
      Search Result for "|||"